![]() | OperationIFCExportFlags Structure |
Boolean flags for IFC 4 export.
Namespace: Tekla.Structures.Model.Operations
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The OperationIFCExportFlags type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsSpacesEnabled |
Boolean indicating whether the export of spaces in building hierarchy is enabled.
|
![]() | UseIfcMapConversion |
Boolean indicating whether to use IfcMapConversion with base points is enabled.
By default IFC4 export should use IfcMapConversion. Uninitialized null will be converted to true during export.
|

Name | Description | |
---|---|---|
![]() | ExportRebarSetGroupAsIndividualBars |
Rebar set group individual bars export is enabled.
|
![]() | IsAssembliesEnabled |
Boolean indicating whether the assemblies export is enabled.
|
![]() | IsBoltsEnabled |
Boolean indicating whether the bolts export is enabled.
|
![]() | IsFlatBeamsAsPlates |
Export flat beams as plates.
|
![]() | IsGridsEnabled |
Boolean indicating whether the grids export is enabled.
|
![]() | IsLocationFromBuildingHierarchy |
Get locations from Building Hierarchy.
|
![]() | IsLocationFromOrganizer |
Get locations from organizer.
|
![]() | IsPoursEnabled |
Pours export is enabled. True for pours, false for CIP cast-units and/or parts
|
![]() | IsRebarsEnabled |
Boolean indicating whether the rebars export is enabled.
|
![]() | IsSurfaceTreatmentsAndSurfacesEnabled |
Boolean indicating whether the surfaces and surface treatments export is enabled.
|
![]() | IsWeldsEnabled |
Boolean indicating whether the welds export is enabled.
|