API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OperationHighlight Method

Highlight the list of objects from the user interface. Only the list of objects will be highlighted, the rest will be unhighlighted. But it will keep the status of the selected objects. To unhighlight give an empty list as a parameter.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public static bool Highlight(
	List<ModelObject> ModelObjects
)

Parameters

ModelObjects
Type: System.Collections.GenericListModelObject
The list of model objects to highlight.

Return Value

Type: Boolean
True on success.
See Also