API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OperationCreateIFC4ExportFromAll Method

Creates IFC4 export from all objects using the given file name.

See Tekla Structures Help for more information about IFC4 export files.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public static bool CreateIFC4ExportFromAll(
	string fullPathAndFileName,
	OperationIFCExportViewTypeEnum exportViewType,
	IEnumerable<string> propertySets,
	OperationExportBasePoint locationByValue,
	string exportLayersAsValue,
	string objectColoring,
	OperationIFCExportFlags flags,
	string basePointGuid
)

Parameters

fullPathAndFileName
Type: SystemString
The full path and file name including extension (.ifc or .ifcZip).
exportViewType
Type: Tekla.Structures.Model.OperationsOperationIFCExportViewTypeEnum
The export view type.
propertySets
Type: System.Collections.GenericIEnumerableString
The full path and file name of the property set files (.xml) to use in export.
locationByValue
Type: Tekla.Structures.Model.OperationsOperationExportBasePoint
The location by value.
exportLayersAsValue
Type: SystemString
The export layers as value: __Name__, __Phase__ or UDA value.
objectColoring
Type: SystemString
The object coloring value: Use "ByObjectClass" for color by object class. For additional coloring, use the name of the object representation.
flags
Type: Tekla.Structures.Model.OperationsOperationIFCExportFlags
The additional flags.
basePointGuid
Type: SystemString
Base point guid, if a base point used.

Return Value

Type: Boolean
True, if Ifc4 export was successful, otherwise false. See session log for additional info in case failure.
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Model.Operations;

public class Example
{
       public void Example1()
       {
           var fullPathAndFileName = @"C:\Export\MyIfc.ifc";
           var exportViewType = Operations.Operation.IFCExportViewTypeEnum.REFERENCE_VIEW;
           var propertySets = new List<string> { @"..\\default\\General\\Shared\\IFC\\AdditionalPSets\\CIP Construction data.xml" };
           var locationByValue = Operations.Operation.ExportBasePoint.GLOBAL;
           var exportLayersAsValue =  "__Name__";
           var objectColoring = "ByObjectClass";
           var flags = new Operations.Operation.IFCExportFlags { IsLocationFromOrganizer = true, IsPoursEnabled = true };
           var basePointGuid = string.Empty;

           if (Operation.CreateIFC4ExportFromAll(fullPathAndFileName, exportViewType, propertySets, locationByValue, exportLayersAsValue, objectColoring, flags, basePointGuid))
           {
                MessageBox.Show("Ifc4 export creation successful");
           }
       }
}
See Also