API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

RebarSpacingCreate Method (RebarSpacingOffset, RebarSpacingOffset, IEnumerableRebarSpacingExactSpacingElement, RebarSpacingExactSpacingValidation)

Creates an exact spacing if the given elements are valid.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public static RebarSpacing Create(
	RebarSpacingOffset startOffset,
	RebarSpacingOffset endOffset,
	IEnumerable<RebarSpacingExactSpacingElement> elements,
	out RebarSpacingExactSpacingValidation validation
)

Parameters

startOffset
Type: Tekla.Structures.ModelRebarSpacingOffset
The start offset.
endOffset
Type: Tekla.Structures.ModelRebarSpacingOffset
The end offset.
elements
Type: System.Collections.GenericIEnumerableRebarSpacingExactSpacingElement
The elements.
validation
Type: Tekla.Structures.ModelRebarSpacingExactSpacingValidation
Returns a value indicating the validity of the elements.

Return Value

Type: RebarSpacing
A RebarSpacing instance.
See Also