API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelObjectSetUserProperties Method

Sets multiple properties for the model object.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool SetUserProperties(
	List<string> stringPropertyNames,
	List<string> stringValues,
	List<string> doublePropertyNames,
	List<double> doubleValues,
	List<string> intPropertyNames,
	List<int> intValues
)

Parameters

stringPropertyNames
Type: System.Collections.GenericListString
The names of the string properties to be set.
stringValues
Type: System.Collections.GenericListString
The new values for the string properties.
doublePropertyNames
Type: System.Collections.GenericListString
The names of the double properties to be set.
doubleValues
Type: System.Collections.GenericListDouble
The new values for the double properties.
intPropertyNames
Type: System.Collections.GenericListString
The names of the int properties to be set.
intValues
Type: System.Collections.GenericListInt32
The new values for the int properties.

Return Value

Type: Boolean
True if the property was set successfully.
See Also