API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AssemblySetUserDefinedCoordSys Method

Set user defined assembly coordinate system. If set, GetCoordinateSystem will return this value.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool SetUserDefinedCoordSys(
	CoordinateSystem coordinateSystem
)

Parameters

coordinateSystem
Type: Tekla.Structures.Geometry3dCoordinateSystem
The coordinate system.

Return Value

Type: Boolean
True if successful.
Remarks
Currently only supported with rebar assemblies.
See Also