API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AssemblySetMainObject Method

Sets the main object of the assembly.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool SetMainObject(
	ModelObject mainObject
)

Parameters

mainObject
Type: Tekla.Structures.ModelModelObject
The Part, Reinforcement, or RebarSet object to set as the main object of the assembly.

Return Value

Type: Boolean
True if the object is valid; otherwise false.
See Also