API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

MatrixMultiply Operator (Matrix, IEnumerablePoint)

Transforms the given points using the given matrix.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static IEnumerable<Point> operator *(
	Matrix A,
	IEnumerable<Point> Points
)

Parameters

A
Type: Tekla.Structures.Geometry3dMatrix
The transformation matrix.
Points
Type: System.Collections.GenericIEnumerablePoint
The points to be transformed.

Return Value

Type: IEnumerablePoint
The new transformed points.
See Also