API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ProfileItemGetHighAccuracyCrossSection Method

Get cross section with high accuracy.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public CrossSection GetHighAccuracyCrossSection(
	double RelativeLocation = 0
)

Parameters

RelativeLocation (Optional)
Type: SystemDouble
The relative location of the cross section, values between 0 (start of profile) and 1 (end of profile).

Return Value

Type: CrossSection
CrossSection object or null on failure.
See Also