API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

GenericDelegateProxyI, T Class

Generic delegate proxy class
Inheritance Hierarchy
SystemObject
  Tekla.Structures.RemotingHelperGenericDelegateProxyI, T

Namespace:  Tekla.Structures.RemotingHelper
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class GenericDelegateProxy<I, T>
where I : class
where T : new(), MarshalByRefObject, I

Type Parameters

I
Interface class type
T
Delegate class type

The GenericDelegateProxyI, T type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyDelegate
Gets the CDelegate instance
Top
See Also