API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OperationSetHandlePoints Method

Set the Shape Item Handle Points

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public static bool SetHandlePoints(
	string guid,
	List<Point> HandlePoints
)

Parameters

guid
Type: SystemString
The guid of the shape
HandlePoints
Type: System.Collections.GenericListPoint
An array of handle points

Return Value

Type: Boolean
True if the appending operation was successful
See Also