API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ReferenceModelGetReferenceModelObjectGuidsByExternalGuids Method

Gets reference model object guids by external guids.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public List<string> GetReferenceModelObjectGuidsByExternalGuids(
	List<string> externalGuids
)

Parameters

externalGuids
Type: System.Collections.GenericListString
The external guids.

Return Value

Type: ListString
If successful, the reference model object guids.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.