API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelHandlerSave Method (String, String, String)

Saves current model with comment and user information.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool Save(
	string Comment,
	string User,
	string Reason
)

Parameters

Comment
Type: SystemString
The comment for save operation, used only with multi-user models.
User
Type: SystemString
The user identification, used only with multi-user models.
Reason
Type: SystemString
The reason why this model save is being called. Used for identifying model save events.

Return Value

Type: Boolean
True on success.
See Also