API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ClashCheckHandlerRunClashCheckWithOptions Method (Boolean, Boolean, Double, Boolean)

Starts the clash checking with options.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool RunClashCheckWithOptions(
	bool betweenReferenceModels,
	bool objectsInsideReferenceModels,
	double minDistance,
	bool betweenParts
)

Parameters

betweenReferenceModels
Type: SystemBoolean
True, if clash check should be performed between reference models.
objectsInsideReferenceModels
Type: SystemBoolean
True, if clash check should be performed to objects inside reference models.
minDistance
Type: SystemDouble
The minimum distance value.
betweenParts
Type: SystemBoolean
True, if clash check should be performed between native parts.

Return Value

Type: Boolean
True on success.
See Also