API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BrepType Enumeration

Shape catalog renewal makes it possible to organize shapes in the shape catalog compared to a plain list before. Thus, it is now possible and required to distinguish shapes in such a manner that: BuildingProduct represent shapes that users can import from, for example, Tekla Warehouse and insert them into a model. These are usually provided by the manufacturer and not detailed by users themselves. StructuralShape represent shapes that get created by "Convert part to item" or from geometry editing.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public enum BrepType
Members
  Member nameValueDescription
BuildingProduct0 Default value if the flag doesn't exist for the shape. It is also assigned in case of shape import.
StructuralShape1 StructuralShape is assigned in case a shape is created by "Convert part to item", or on shape edit and save.
See Also