![]() | AnalysisModelGeneralProperties Class |
The AnalysisModelGeneralProperties class contains the general property information for an analysis model.

Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1

The AnalysisModelGeneralProperties type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisModelGeneralProperties |
Creates a new analysis model general properties instance.
|

Name | Description | |
---|---|---|
![]() | AnalysisEngineName |
The name of the analysis engine.
|
![]() | ExtendedClashCheck |
Defines whether the extended clash check is used.
|
![]() | FilterName |
The name of the filter.
|
![]() | MemberAxisLocation |
The location of the member axis.
|
![]() | MemberEndReleaseMethodByConnection |
Defines whether the support conditions of connections or parts are used.
|
![]() | ModalAnalysisModel |
Defines whether the modal analysis properties are used instead of the static load combinations.
|
![]() | ModelCreationType |
The model creation type.
|
![]() | ModelMerging |
Defines whether the model merging is used.
|
![]() | ModelName |
The name of the model.
|
![]() | NodeDefinition |
Defines how the nodes and node positions are defined.
|