API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisLocalCoordinateSystem Class

The AnalysisLocalCoordinateSystem class contains local coordinate system information for an analysis model.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisLocalCoordinateSystem

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1
Syntax
public class AnalysisLocalCoordinateSystem

The AnalysisLocalCoordinateSystem type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisLocalCoordinateSystem
Creates a new analysis local coordinate system instance.
Top
Properties
  NameDescription
Public propertyLocalX
The local X direction.
Public propertyLocalY
The local Y direction.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.