API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisDesignSettings Class

The AnalysisDesignSettings class contains information about analysis design settings.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisDesignSettings

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1
Syntax
public class AnalysisDesignSettings

The AnalysisDesignSettings type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisDesignSettings
Creates a new analysis design settings instance.
Top
Properties
  NameDescription
Public propertyConcreteDesignCode
The concrete design code.
Public propertyConcreteDesignMethod
The concrete design method.
Public propertySteelDesignCode
The steel design code.
Public propertySteelDesignMethod
The steel design method.
Public propertyTimberDesignCode
The timber design code.
Public propertyTimberDesignMethod
The timber design method.
Top
See Also