API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerPickPoint Method (Point)

Queries the user to pick a point from the model with reference to the given point.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public Point PickPoint(
	Point ReferencePoint
)

Parameters

ReferencePoint
Type: Tekla.Structures.Geometry3dPoint
The point to be used as reference.

Return Value

Type: Point
The point the user picked.
See Also