API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

EnvironmentFilesGetAttributeFiles Method

Gets attribute files with specified suffix from model, XS_FIRM and XS_PROJECT directories and subdirectories.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public static List<string> GetAttributeFiles(
	string suffix
)

Parameters

suffix
Type: SystemString
The filename suffix.

Return Value

Type: ListString
A list of found file names
See Also