RebarItemEnumeratorSelectRebarItem Method (String, String, String, String)

Selects a rebar item in the rebar database with the given grade, size, usage and code.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
public static RebarItem SelectRebarItem(
	string Grade,
	string Size,
	string Usage,
	string Code
)

Parameters

Grade
Type: SystemString
The grade of the rebar item to select.
Size
Type: SystemString
The size of the rebar item to select.
Usage
Type: SystemString
The usage of the rebar item to select.
Code
Type: SystemString
The code of the rebar item to select.

Return Value

Type: RebarItem
The first RebarItem that matches the conditions.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next