API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

RebarItemEnumeratorModifyRebarItem Method

Modify the RebarItem in the list

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public static bool ModifyRebarItem(
	RebarItem rebarItem,
	RebarItem originalRebarItem
)

Parameters

rebarItem
Type: Tekla.Structures.CatalogsRebarItem
item to modify
originalRebarItem
Type: Tekla.Structures.CatalogsRebarItem
original Rebar Item to match

Return Value

Type: Boolean
True on success
See Also