API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OperationMoveAnalysisPartPosition Method

Moves the analysis part position by translation vector. Only the handle positions can be moved.

Namespace:  Tekla.Structures.Analysis.Operations
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1
Syntax
public static bool MoveAnalysisPartPosition(
	AnalysisPart analysisPart,
	AnalysisNode node,
	Vector translation
)

Parameters

analysisPart
Type: Tekla.Structures.AnalysisAnalysisPart
The analysis part.
node
Type: Tekla.Structures.AnalysisAnalysisNode
The node.
translation
Type: Tekla.Structures.Geometry3dVector
The vector for moving the position.

Return Value

Type: Boolean
True on success, false on failure.
See Also