API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OperationMoveAnalysisPartAreaEdge Method

Moves the analysis part area edge by translation vector. Perpendicular offset is calculated from the translation vector.

Namespace:  Tekla.Structures.Analysis.Operations
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1
Syntax
public static bool MoveAnalysisPartAreaEdge(
	AnalysisPart analysisPart,
	AnalysisNode edgeNode1,
	AnalysisNode edgeNode2,
	Vector translation
)

Parameters

analysisPart
Type: Tekla.Structures.AnalysisAnalysisPart
The analysis part.
edgeNode1
Type: Tekla.Structures.AnalysisAnalysisNode
Edge node 1.
edgeNode2
Type: Tekla.Structures.AnalysisAnalysisNode
Edge node 2.
translation
Type: Tekla.Structures.Geometry3dVector
The vector for moving the edge.

Return Value

Type: Boolean
True on success, false on failure.
See Also