API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Operation Class

Operations of analysis objects.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Analysis.OperationsOperation

Namespace:  Tekla.Structures.Analysis.Operations
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1
Syntax
public class Operation

The Operation type exposes the following members.

Constructors
  NameDescription
Public methodOperation
Initializes a new instance of the Operation class
Top
Methods
  NameDescription
Public methodStatic memberMoveAnalysisPartAreaEdge
Moves the analysis part area edge by translation vector. Perpendicular offset is calculated from the translation vector.
Public methodStatic memberMoveAnalysisPartPosition
Moves the analysis part position by translation vector. Only the handle positions can be moved.
Public methodStatic memberMoveObject
Moves the analysis object by translation vector. Supported objects are: AnalysisNode, AnalysisPart.
Public methodStatic memberResetAnalysisPartPositions
Reset analysis part. Removes the offsets applied to node positions. The axis offset of the analysis part is not reset.
Top
See Also