API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LoftedPlateInsert Method

Inserts the lofted plate into the model database. All the attributes must be set and there must be at minimum 2 base curves.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public override bool Insert()

Return Value

Type: Boolean
True on success.
Exceptions
ExceptionCondition
LoftedPlateOperationException Thrown if the input base curves would yield an invalid lofted plate. The most derived type of the exception can be used to retrieve the actual source of error.
See Also