API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ConicalSurface Constructor (Arc, Double, Double)

Initializes a new instance of the ConicalSurface class from a base arc, a height and a radius at the top. This is the recommended constructor if no intermediate points are desired along the lateral boundaries of the bend surface.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ConicalSurface(
	Arc baseArc,
	double height,
	double radiusAtHeight
)

Parameters

baseArc
Type: Tekla.Structures.Geometry3dArc
Arc to form the base of the bend surface
height
Type: SystemDouble
Height of the surface measured along the normal of the arc, may be positive or negative, but always nonzero
radiusAtHeight
Type: SystemDouble
Radius of the arc located at the given height. Must be positive
Exceptions
ExceptionCondition
ArgumentExceptionThrown if the given lengths are invalid
See Also