API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

TeklaStructuresSettingsInvalidPathCallback Delegate

The invalid path callback - provides error logging for GetAdvancedOptionPaths when a string is found to be invalid as a path

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public delegate void InvalidPathCallback(
	string advancedOption,
	string invalidString,
	string exceptionMessage
)

Parameters

advancedOption
Type: SystemString
The advanced option name.
invalidString
Type: SystemString
The invalid string.
exceptionMessage
Type: SystemString
The exception message if an exception was thrown when converting the string to a path.
See Also