API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

RebarLengthAdjustmentDataNullable Class

The RebarLengthAdjustmentDataNullable class defines the length adjustment at the end of a reinforcing bar affected by a RebarEndDetailModifier. If a length adjustment property is null then that property will not be applied to the RebarSet generated reinforcing bars.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelRebarLengthAdjustmentDataNullable

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class RebarLengthAdjustmentDataNullable

The RebarLengthAdjustmentDataNullable type exposes the following members.

Constructors
  NameDescription
Public methodRebarLengthAdjustmentDataNullable
Initializes a new instance of the RebarLengthAdjustmentDataNullable class.
Top
Properties
  NameDescription
Public propertyAdjustmentLength
Gets or sets the adjustment length.
Public propertyAdjustmentType
Gets or sets the adjustment type.
Top
See Also