RebarLapping Class

The RebarLapping class represents the lapping of reinforcing bars at a RebarSplitter.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelRebarLapping

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class RebarLapping

The RebarLapping type exposes the following members.

Constructors
  NameDescription
Public methodRebarLapping
Initializes a new instance of the RebarLapping class.
Top
Properties
  NameDescription
Public propertyLapLength
Gets or sets the lap length. Negative values will define a gap rather than a lap.
Public propertyLappingType
Gets or sets the lapping type.
Public propertyLapPlacement
Gets or sets the placement of the lap relative to the associated RebarLegFace.
Public propertyLapSide
Gets or sets the side of the split that the lap is located.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next