![]() | RebarCranking Class |
The RebarCranking class represents the cranking of reinforcing bars at a RebarSplitter.

Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The RebarCranking type exposes the following members.

Name | Description | |
---|---|---|
![]() | RebarCranking |
Initializes a new instance of the RebarCranking class.
|

Name | Description | |
---|---|---|
![]() | CrankedDistance |
Gets or sets the cranked distance.
|
![]() | CrankedLengthType |
Gets or sets the cranked length type.
|
![]() | CrankedOffset |
Gets or sets the cranked offset.
|
![]() | CrankedRatio |
Gets or sets the cranked ratio.
|
![]() | CrankingType |
Gets or sets the cranking type.
|
![]() | CrankRotation |
Gets or sets the crank rotation.
|
![]() | CrankSide |
Gets or sets the crank side.
|
![]() | CrankStraightLength |
Gets or sets the crank straight length.
|