![]() | RadialGrid Class |
The RadialGrid class defines a user defined (possibly magnetic) set;
radial grid has grid planes and cylindrical grid planes as children

SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelGridBase
Tekla.Structures.ModelRadialGrid
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelGridBase
Tekla.Structures.ModelRadialGrid
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The RadialGrid type exposes the following members.

Name | Description | |
---|---|---|
![]() | RadialGrid |
Creates a new radial grid instance. Overrides the default creation parameters by forcing the angular
coordinates to be "0.0 6*15.0"
|

Name | Description | |
---|---|---|
![]() | AngularCoordinates |
The angular coordinates of the grid lines
|
![]() | AngularLabels |
The labels for the angular grid lines.
|
![]() | AngularLinesEndExtension |
The extension of the angular grid lines at their end point.
|
![]() | AngularLinesStartExtension |
The extension of the angular grid lines at their start point.
|
![]() | ArcEndExtension |
The extension of the grid arcs at their end point.
|
![]() | ArcStartExtension |
The extension of the grid arcs at their start point.
|
![]() | Color |
Gets or sets the color of the grid.
|
![]() | CoordinateZ |
The coordinates for the Z-axis.
|
![]() | ExtensionAboveZ |
The extension above Z-axis.
|
![]() | ExtensionBelowZ |
The extension below the Z-axis.
|
![]() | FontColor |
Gets or sets font color for the grid labels
(Inherited from GridBase.) |
![]() | FontSize |
Gets or sets font size for the grid labels
(Inherited from GridBase.) |
![]() | Identifier |
The identifier of the object.
(Inherited from Object.) |
![]() | IsMagnetic |
Gets or sets whether the grid is magnetic or not
(Overrides GridBaseIsMagnetic.) |
![]() | IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) |
![]() | LabelZ |
The labels for the Z-axis.
|
![]() | ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) |
![]() | Name |
Gets or sets the name of the grid.
(Inherited from GridBase.) |
![]() | Origin |
Gets or sets the origin of the grid
(Inherited from GridBase.) |
![]() | RadialCoordinates |
The distances between the radii of the arcs
|
![]() | RadialLabels |
The labels for the grid arcs.
|

Name | Description | |
---|---|---|
![]() | CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) |
![]() | Delete |
Deletes the grid with the given ID.
(Inherited from GridBase.) |
![]() | Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) |
![]() ![]() | GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) |
![]() | GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) |
![]() | GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) |
![]() | GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) |
![]() | GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) |
![]() | GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) |
![]() | GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) |
![]() | GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) |
![]() | GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) |
![]() | GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) |
![]() | Insert |
Inserts the grid into the model.
(Inherited from GridBase.) |
![]() | Modify |
Modifies the grid with the given ID.
(Inherited from GridBase.) |
![]() | Select |
Selects the grid with the given ID.
(Inherited from GridBase.) |
![]() | SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) |
![]() | SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) |
![]() | SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |

using Tekla.Structures.Model; public class Example { public void Example1() { RadialGrid grid = new RadialGrid(); grid.IsMagnetic = true; bool Result = Grid.Insert(); } }