GridCylindricalSurface Class

The GridCylindricalSurface class defines a user defined (possibly magnetic) cylindrical surface helping in modeling work. A grid cylindrical surface must always belong to a parent grid instance.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class GridCylindricalSurface : GridSurface

The GridCylindricalSurface type exposes the following members.

Constructors
  NameDescription
Public methodGridCylindricalSurface
Creates a new grid plane instance.

The default values are as follows:

  • CylinderBase = new Arc(new Point(0, 0, 0), new Point(6000, 0, 0), new Vector(0, 0, 1), Math.PI);
  • CylinderHeight = 6000.0;
  • Label = "Default";
  • IsMagnetic = false;
  • ExtensionLeft = 2000.0;
  • ExtensionRight = 2000.0;
  • ExtensionBelow = 2000.0;
  • ExtensionAbove = 2000.0;
  • DrawingVisibility = false;
Public methodGridCylindricalSurface(Arc, Double, String)
Creates a new grid plane instance taking the plane and label as input.
Top
Properties
  NameDescription
Public propertyCylinderBase
The arc that represents the base of the cylindrical surface. The cylinder is then extruded along the normal direction of the arc, with the height given by CylinderHeight"
Public propertyCylinderHeight
Height of the cylinder along the normal direction of the CylinderBase arc.
Public propertyDrawingVisibility
The visibility of the grid surface in drawings.
(Inherited from GridSurface.)
Public propertyExtensionAbove
The line extension above.
(Inherited from GridSurface.)
Public propertyExtensionBelow
The line extension below.
(Inherited from GridSurface.)
Public propertyExtensionLeft
The line extension on the left.
(Inherited from GridSurface.)
Public propertyExtensionRight
The line extension on the right.
(Inherited from GridSurface.)
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIsMagnetic
Whether the grid surface is magnetic or not.
(Inherited from GridSurface.)
Public propertyIsManual
Gets or sets if the line was manually created.
(Inherited from GridSurface.)
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyLabel
The label for the grid surface.
(Inherited from GridSurface.)
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyParent
The parent grid of the grid surface.
(Inherited from GridSurface.)
Top
Methods
  NameDescription
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the grid surface with the given ID.
(Inherited from GridSurface.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodInsert
Inserts the grid surface into the model.
(Inherited from GridSurface.)
Public methodModify
Modifies the grid plane with the given ID.
(Overrides GridSurfaceModify.)
Public methodSelect
Selects the grid surface with the given ID.
(Inherited from GridSurface.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
Examples
using System;
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public bool Example1()
       {
           var cylindricalSurface = new GridCylindricalSurface();

           Arc cylinderBase = new Arc(new Point(0,0,0), new Point(6000,0,0), new Vector(0,0,1), Math.PI);
           double cylinderHeight = 6000.0;

           cylindricalSurface.CylinderBase = cylinderBase;
           cylindricalSurface.CylinderHeight = cylinderHeight;

           return cylindricalSurface.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next