GridCylindricalSurface Class

The GridCylindricalSurface class defines a user defined (possibly magnetic) cylindrical surface helping in modeling work. A grid cylindrical surface must always belong to a parent grid instance.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class GridCylindricalSurface : GridSurface

The GridCylindricalSurface type exposes the following members.

Constructors
  NameDescription
Public methodGridCylindricalSurface
Creates a new grid plane instance.

The default values are as follows:

  • CylinderBase = new Arc(new Point(0, 0, 0), new Point(6000, 0, 0), new Vector(0, 0, 1), Math.PI);
  • CylinderHeight = 6000.0;
  • Label = "Default";
  • IsMagnetic = false;
  • ExtensionLeft = 2000.0;
  • ExtensionRight = 2000.0;
  • ExtensionBelow = 2000.0;
  • ExtensionAbove = 2000.0;
  • DrawingVisibility = false;
Public methodGridCylindricalSurface(Arc, Double, String)
Creates a new grid plane instance taking the plane and label as input.
Top
Properties
  NameDescription
Public propertyCylinderBase
The arc that represents the base of the cylindrical surface. The cylinder is then extruded along the normal direction of the arc, with the height given by CylinderHeight"
Public propertyCylinderHeight
Height of the cylinder along the normal direction of the CylinderBase arc.
Top
Methods
  NameDescription
Public methodModify
Modifies the grid plane with the given ID.
(Overrides GridSurfaceModify.)
Top
Examples
using System;
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public bool Example1()
       {
           var cylindricalSurface = new GridCylindricalSurface();

           Arc cylinderBase = new Arc(new Point(0,0,0), new Point(6000,0,0), new Vector(0,0,1), Math.PI);
           double cylinderHeight = 6000.0;

           cylindricalSurface.CylinderBase = cylinderBase;
           cylindricalSurface.CylinderHeight = cylinderHeight;

           return cylindricalSurface.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next