API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ControlArcGeometry Property

Gets or sets the arc geometry. The arc must not represent a complete circle (i.e. the arc angle must be less than 360 degrees).

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public Arc Geometry { get; set; }

Property Value

Type: Arc
Exceptions
ExceptionCondition
ArgumentExceptionThrown if the input arc is a complete circle
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.