API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PolycurveGeometryBuilderReplace Method (Int32, Arc)

Replaces the geometry at a given index

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public PolycurveGeometryBuilder Replace(
	int index,
	Arc arc
)

Parameters

index
Type: SystemInt32
Index of the geometry to replace
arc
Type: Tekla.Structures.Geometry3dArc
Geometry to insert in place of the existing one

Return Value

Type: PolycurveGeometryBuilder
The builder itself
See Also