API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PolycurveGeometryBuilderPrependArc Method

Prepends an arc using three points. The last point is taken as the start point of the first element of the polycurve.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public PolycurveGeometryBuilder PrependArc(
	Point startPoint,
	Point middlePoint
)

Parameters

startPoint
Type: Tekla.Structures.Geometry3dPoint
Arc start point
middlePoint
Type: Tekla.Structures.Geometry3dPoint
Arc middle point

Return Value

Type: PolycurveGeometryBuilder
The builder itself
Remarks
This function requires that there is at least one curve in the polycurve
See Also