API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PolycurveGeometryBuilderAppendSegment Method

Appends an line segment. The first point is taken as the last point of the last element of the polycurve.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public PolycurveGeometryBuilder AppendSegment(
	Point endPoint
)

Parameters

endPoint
Type: Tekla.Structures.Geometry3dPoint
Segment end point

Return Value

Type: PolycurveGeometryBuilder
The builder itself
Remarks
This function requires that there is at least one curve in the polycurve
See Also