![]() | PolycurveGeometryBuilderAppend Method (LineSegment) |
Appends a line segment to the geometry list
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1

Parameters
- segment
- Type: Tekla.Structures.Geometry3dLineSegment
Geometry to append
Return Value
Type: PolycurveGeometryBuilderThe builder itself

Exception | Condition |
---|---|
ArgumentException | Thrown if input geometry is not connected to the polycurve |