API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PolycurveGeometryBuilderAppend Method (Arc)

Appends an arc to the geometry list

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public PolycurveGeometryBuilder Append(
	Arc arc
)

Parameters

arc
Type: Tekla.Structures.Geometry3dArc
Geometry to append

Return Value

Type: PolycurveGeometryBuilder
The builder itself
Exceptions
ExceptionCondition
ArgumentExceptionThrown if input geometry is not connected to the polycurve
See Also