Polycurve Class

Represents 3D polycurve geometry, which itself is composed of one or more connected curves. The class offers facilities for iteration through the polycurve, and implements the ICurve interface. Once this class is constructed, it represents an immutable polycurve. The curves that can be obtained during iteration are mere copies of the curves in the polycurve, and mutating them won't affect the polycurve. Please use the PolycurveGeometryBuilder class to build and manipulate this objects of this class. Since it implements IEnumerable, the curves can be iterated using foreach loops, and it supports all of the LINQ operations, and it is possible to build arbitrarily complex queries over the curves of this class.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Geometry3dPolycurve

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class Polycurve : IEnumerable<ICurve>, 
	IEnumerable, ICurve, IEquatable<ICurve>

The Polycurve type exposes the following members.

Constructors
  NameDescription
Public methodPolycurve
Initializes a new instance of the Polycurve class.
Public methodPolycurve(ICurve)
Initializes a new instance of the Polycurve class from a curve geometry.
Public methodPolycurve(PolyLine)
Initializes a new instance of the Polycurve class from a PolyLine. The lines are converted to line segments.
Top
Properties
  NameDescription
Public propertyEndPoint
Gets the end point of the polycurve
Public propertyLength
Gets the total length of the polycurve
Public propertyStartPoint
Gets the start point of the polycurve
Top
Methods
  NameDescription
Public methodClone
Creates a deep copy of the polycurve
Public methodEquals
Determines whether the polycurve equals another polycurve This function only checks for equality among polycurves
Public methodGetEnumerator
This method implements the IEnumerable interface
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next