API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ICurve Interface

Interface that represents an abstract curved geometry defined by a set of points. This interface is intended to be the base class of 3D curves.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public interface ICurve : IEquatable<ICurve>

The ICurve type exposes the following members.

Properties
  NameDescription
Public propertyEndPoint
Gets the end point of the curve. May be the same as StartPoint if the curve is closed.
Public propertyLength
Gets the length of the curve
Public propertyStartPoint
Gets the start point of the curve
Top
Methods
  NameDescription
Public methodClone
Returns a deep copy of the geometry
Top
See Also