API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Arc Constructor (Point, Point, Point)

Constructs a new arc geometry

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public Arc(
	Point startPoint,
	Point endPoint,
	Point pointOnArc
)

Parameters

startPoint
Type: Tekla.Structures.Geometry3dPoint
Start point of the arc.
endPoint
Type: Tekla.Structures.Geometry3dPoint
End point of the arc.
pointOnArc
Type: Tekla.Structures.Geometry3dPoint
Point that defines the arc.
Exceptions
ExceptionCondition
ArgumentExceptionThrows when input points are not defined correctly
See Also