![]() | Arc Class |
Represents an arc geometry

Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1

The Arc type exposes the following members.

Name | Description | |
---|---|---|
![]() | Arc(Point, Point, Point) |
Constructs a new arc geometry
|
![]() | Arc(Point, Point, Vector, Double) |
Constructs a new arc geometry
|
![]() | Arc(Point, Vector, Vector, Double, Double) |
Constructs a new arc geometry
|

Name | Description | |
---|---|---|
![]() | Angle |
Gets angle of the arc in radians.
|
![]() | ArcMiddlePoint |
Gets the point located at the middle of the arc
|
![]() | CenterPoint |
Gets or sets center point of the arc.
|
![]() | EndPoint |
Gets or sets end point of the arc.
|
![]() | Length |
Returns the length of the arc
|
![]() | Normal |
Gets normal of the arc, which defines the axis of rotation of the radial vector pointing to the start point
of the arc.
|
![]() | Radius |
Gets the radius of the arc.
|
![]() | StartDirection |
Gets the unit vector which points from the center point to the start point of the arc, which defines the
X axis of the arc coordinate system.
|
![]() | StartPoint |
Gets or sets start point of the arc.
|
![]() | StartTangent |
Gets the unit vector tangent to the start point which defines the Y axis of the arc coordinate system
|

Name | Description | |
---|---|---|
![]() | Clone |
Returns a copy of itself
|
![]() | Equals(Object) |
Checks for equality with another arc
(Overrides ObjectEquals(Object).) |
![]() | Equals(ICurve) |
Checks for equality with another curve
|
![]() | GetHashCode |
Get HashCode override
(Overrides ObjectGetHashCode.) |