API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SettingsTryGetValueT Method (String, T)

Tries to get the value of the setting with the given name and given object type.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
public static bool TryGetValue<T>(
	string name,
	out T obj
)

Parameters

name
Type: SystemString
The name of the setting.
obj
Type: T
The value of the given setting.

Type Parameters

T
Type of the object to get

Return Value

Type: Boolean
True on success, false otherwise.
See Also