API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AngleListParse Method (String, IFormatProvider)

Parses the given text as an angle list in the current unit type

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
public static List<Angle> Parse(
	string text,
	IFormatProvider formatProvider
)

Parameters

text
Type: SystemString
Text to parse
formatProvider
Type: SystemIFormatProvider
Format provider

Return Value

Type: ListAngle
Resulting angle list from the text
See Also