API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AngleTryParse Method (String, Angle)

Parses the given text as an angle in the current unit type

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
public static bool TryParse(
	string text,
	out Angle result
)

Parameters

text
Type: SystemString
Text to parse
result
Type: Tekla.Structures.DatatypeAngle
Resulting angle if success

Return Value

Type: Boolean
True if the conversion succeeds, false otherwise
See Also