API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AngleToString Method (String, IFormatProvider, AngleUnitType)

Converts the represented angle to a string with the given parameters

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
public string ToString(
	string format,
	IFormatProvider formatProvider,
	AngleUnitType angleUnit
)

Parameters

format
Type: SystemString
The format string. Can be null.
formatProvider
Type: SystemIFormatProvider
The number format provider.
angleUnit
Type: Tekla.Structures.DatatypeAngleUnitType
The unit type.

Return Value

Type: String
This angle as a string
See Also