API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AngleFromCurrentUnit Method

Creates an angle given in the current unit type

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1
Syntax
public static Angle FromCurrentUnit(
	double angle
)

Parameters

angle
Type: SystemDouble
Angle given in the current unit type

Return Value

Type: Angle
An Angle object representing the given angle
See Also