![]() | Angle Class |
Provides support for angles using either the current Tekla Structures units, or user defined units

Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.1

The Angle type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | CurrentUnitType |
Gets or sets the Tekla Structures current angle type
|
![]() | CurrentUnitValue |
Gets the value of the angle in the current unit
|
![]() ![]() | DecimalPlaces |
Gets the number of decimal places used for angles.
|
![]() | Degrees |
Gets the angle value in degrees
|
![]() | Radians |
Gets the angle value in radians
|

Name | Description | |
---|---|---|
![]() | CompareTo |
Compares this angle with another angle
|
![]() | Equals |
Checks for approximate angle equality
|
![]() ![]() | FromCurrentUnit |
Creates an angle given in the current unit type
|
![]() ![]() | FromDegrees |
Creates an angle from a value in degrees
|
![]() ![]() | FromRadians |
Creates an angle from a value in radians
|
![]() ![]() | Parse(String) |
Parses the given text as an angle in the current unit type
|
![]() ![]() | Parse(String, IFormatProvider) |
Parses the given text as an angle in the current unit type
|
![]() ![]() | Parse(String, IFormatProvider, AngleUnitType) |
Parses the given text as an angle in the current unit type
|
![]() | ToString |
Converts the represented angle to a string in the current units
(Overrides ObjectToString.) |
![]() | ToString(AngleUnitType) |
Converts the represented angle to a string in the given units
|
![]() | ToString(String, IFormatProvider) |
Converts the represented angle to a string with the given parameters
|
![]() | ToString(String, IFormatProvider, AngleUnitType) |
Converts the represented angle to a string with the given parameters
|
![]() ![]() | TryParse(String, Angle) |
Parses the given text as an angle in the current unit type
|
![]() ![]() | TryParse(String, IFormatProvider, Angle) |
Parses the given text as an angle in the current unit type
|
![]() ![]() | TryParse(String, IFormatProvider, AngleUnitType, Angle) |
Parses the given text as an angle in the current unit type
|