API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ShapeItemCleanAndModify Method

Cleans and stores the brep into the shape catalog

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public bool CleanAndModify(
	ref bool isSolid
)

Parameters

isSolid
Type: SystemBoolean

[Missing <param name="isSolid"/> documentation for "M:Tekla.Structures.Catalogs.ShapeItem.CleanAndModify(System.Boolean@)"]

Return Value

Type: Boolean
True if cleaning and storing to catalog was successful
See Also